1
0
Fork 0
permafrost/modules/users.nix
2025-01-25 02:22:34 -08:00

33 lines
970 B
Nix

{ config, ... }:
{
nix.settings.trusted-users = [ "ravenshade" ];
# users sops setup
sops.secrets."passwords/ravenshade".neededForUsers = true;
users.mutableUsers = false;
users.users.ravenshade = {
isNormalUser = true;
description = "Zynh Ludwig";
hashedPasswordFile = config.sops.secrets."passwords/ravenshade".path;
extraGroups = [ "networkmanager" "wheel" "docker" "syncthing" ];
};
users.users.espen = {
isNormalUser = true;
description = "Espen's user";
};
users.users.nullcube = {
isNormalUser = true;
description = "NullCube's user";
extraGroups = [ "networkmanager" "wheel" "docker" "syncthing" ];
hashedPassword = "$6$aREIO8qUFoABzNGv$Tcsw7HuV302sjo0z9L8i/FfOx06KUe3WnIIStjm7FkmfoJh.Qx2350qNCE/uIatMUhGjsnBEkht2ClpRi24Ph/";
openssh.authorizedKeys.keys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAID7l6X61Fvlmk0OSn5OWZFiYWBGStwmsDgXQVxxCTFFF nullcube@permafrost from Vulcan"
];
};
}