forked from Zynh0722/permafrost
21 lines
641 B
Nix
21 lines
641 B
Nix
{ pkgs, lib, ... }:
|
|
|
|
{
|
|
systemd.services.enable-screen = {
|
|
description = "disable screen";
|
|
enable = true;
|
|
serviceConfig = {
|
|
Type = "oneshot";
|
|
ExecStart = "${pkgs.coreutils}/bin/cp /sys/class/backlight/intel_backlight/max_brightness /sys/class/backlight/intel_backlight/brightness";
|
|
};
|
|
};
|
|
systemd.services.disable-screen = {
|
|
description = "disable screen";
|
|
enable = true;
|
|
wantedBy = [ "multi-user.target" ];
|
|
serviceConfig = {
|
|
Type = "oneshot";
|
|
ExecStart = "${lib.getExe pkgs.bash} -c '${pkgs.coreutils}/bin/echo 0 > /sys/class/backlight/intel_backlight/brightness'";
|
|
};
|
|
};
|
|
}
|