boids-rs/shell.nix

26 lines
450 B
Nix

{ pkgs ? import <nixpkgs> { }, additionalBuildInputs ? [ ] }:
with pkgs;
mkShell rec {
nativeBuildInputs = [
pkg-config
mold
clang
];
buildInputs = [
udev
alsa-lib
vulkan-loader
xorg.libX11 # To use the x11 feature
xorg.libXcursor
xorg.libXrandr
xorg.libXi
libxkbcommon # To use the wayland feature
wayland
] ++ additionalBuildInputs;
LD_LIBRARY_PATH = lib.makeLibraryPath buildInputs;
}