nixos/builders.nix

75 lines
2.0 KiB
Nix

{ nixpkgs, self, ... }@inputs:
let
makePkgs = system: (import nixpkgs {
inherit system;
config.allowUnfree = true;
overlays = [
self.overlays.default
inputs.niri.overlays.niri
];
});
lib = nixpkgs.lib.extend (import ./lib);
inherit (inputs.home-manager.lib) homeManagerConfiguration;
inherit (lib) nixosSystem;
inherit (lib.strings) optionalString;
inherit (lib.attrsets) nameValuePair;
in
rec {
toPartialNixosConfig =
{ hostname, system ? "x86_64-linux" }:
nameValuePair
hostname
(nixosSystem rec {
pkgs = makePkgs system;
specialArgs = { inherit inputs self; };
modules = [
./hosts/${hostname}/hardware-configuration.nix
./hosts/${hostname}/configuration.nix
inputs.home-manager.nixosModules.default
inputs.niri.nixosModules.niri
inputs.lix-module.nixosModules.default
{
home-manager.extraSpecialArgs = {
inherit inputs self pkgs;
lib = pkgs.lib.extend (_: _: inputs.home-manager.lib);
};
}
];
});
compileSystems =
systems:
lib.right
builtins.listToAttrs
(map toPartialNixosConfig)
systems;
toPartialHomeManagerConfig =
{ user, system ? "x86_64-linux", hostname ? "", configHostname ? "" }:
let
configHost = if builtins.stringLength configHostname > 0 then configHostname else hostname;
hostStr = optionalString (builtins.stringLength hostname > 0) "@${hostname}";
in
assert lib.assertMsg (builtins.stringLength configHost > 0) "either configHostname or hostname need to exist";
nameValuePair
"${user}${hostStr}"
(homeManagerConfiguration {
pkgs = makePkgs system;
extraSpecialArgs = { inherit inputs self; };
modules = [
./hosts/${configHost}/home.nix
];
});
compileHomes =
systems:
lib.right
builtins.listToAttrs
(map toPartialHomeManagerConfig)
systems;
}