repo-clone/repo.nix

24 lines
395 B
Nix

{ lib, ... }:
let
inherit (lib)
types mkOption;
in
types.attrsOf (types.submodule ({ config, ... }: {
options = {
url = mkOption {
type = types.str;
description = ''
Url of git repo to clone
'';
};
extraArgs = mkOption {
type = types.str;
description = ''
Args to be used with the `git clone` command
'';
};
};
}))